Skip to main content
Topic: Offline map not showing up with custom theme (Read 36 times) previous topic - next topic

Offline map not showing up with custom theme

I was planning to post this in the other thread, but it was locked.

I've been using a map from OpenAndroMaps with the Elevate theme for a while now. Recently there was an update that added theme customizability. This was something I've wanted for a long time, and had even requested. The problem is that this update also broke the theme I was using. As you can see from my pictures, the map only shows up if I choose the " " theme, which presumably is a default setting. The default setting is not bad per se, but does not have contour lines. Since I live in a place with lots of elevation changes, it is a must-have for me.

I am not using an SD card, even if the directory says externalstorage for some reason. Everything is stored internally on my Samsung Galaxy S10+.

Re: Offline map not showing up with custom theme

Reply #1
Try reselecting the offline maps folder. Press the folder button next to the field, then press the Android button to allow Geooh access to the folder. When done then there should be a small progress window indicating map files are being set up. After that, see if the theme is working and let me know.

Until Mapsforge updates their software to support the latest Android storage methods, Geooh has to move theme files around internally. I tried to get Geooh do this automatically on the new release, but maybe that didn't occur.

This also works with the SD card.

Re: Offline map not showing up with custom theme

Reply #2
Also, do you have a screenshot of how it should look? Maybe use a different app and point it to the same map/theme directory that Geooh is using to be sure both are using the same files.

Re: Offline map not showing up with custom theme

Reply #3
I've already tried reselecting the folder. I do get the progress bar, but this does not fix the issue. Fairly sure I even tried reinstalling the entire Geooh app, to no avail.

I've attached some pictures of what the same map looks like in Locus. Excuse all the POIs on the map, I couldn't figure out how to disable them (never used the app before).

(Again it says sdcard, but it's actually on internal storage)

Re: Offline map not showing up with custom theme

Reply #4
Try c:geo... Locus has their own software and map viewer. Geooh uses Mapsforge like c:geo does so if similar in c:geo, there may not be much Geooh can do since it is Mapsforge that is doing the rendering of map tiles.

Re: Offline map not showing up with custom theme

Reply #5
Here is c:geo.

(The theme loaded fine in geooh go too before the update, just without customizability.)


Re: Offline map not showing up with custom theme

Reply #6
I finally found where the issue was... Geooh wasn't properly enabling the theme background. It's been corrected and should fix the issue you reported. I'll publish a new release in the next day or so.

Thanks for the clear examples and explanation... took me longer than I wanted to find what Mapsforge was wanting for the theme, but all should be good with the new version.

Re: Offline map not showing up with custom theme

Reply #7
Map themes work much better in version 11.4.4!
Thank you!

If I catch a specific bug now, it will probably be easier to find.

 

Re: Offline map not showing up with custom theme

Reply #8
Thanks for the feedback. I was planning on checking with you to see if the update fixed it for you. My testing showed virtually identical map displays as c:geo... the only differences were street names showing, but I think that was based on minor zoom differences which causes Mapsforge to display differently.